JDBC及Mybatis常见BUG

问题描述

因为平时都是Springboot简化配置,感觉有点手生,所以今天上Mybatis课的时候手写了一下JDBC以及Mybatis,同时出现了几个问题,在此记录一下。

0x01 JDBC插入中文乱码

代码如下

image-20220228230148659

控制台打印结果时字符依然正常

image-20220228230219634

但是在数据库中刚刚插入的汉字为乱码。

image-20220228230234717

由此可以判断出字符在后端到数据库时出现字符编码不同。

检查配置文件,如下

image-20220228230342565

经过检查发现url后面的UseUnicode和CharacterEncoding书写问题,正确写法应该首字母小写,如下

1
jdbc.url=jdbc:mysql://localhost:3306/test1?useUnicode=true&characterEncoding=utf-8&useSSL=false

image-20220228230451900

问题解决

image-20220228230542838

0x02 Mybatis mapper文件找不到

pass: 此处的Mybatis没有使用Spring集成

报错如下:

java.lang.ExceptionInInitializerError

1
2
3
4
5
6
7
8
9
Caused by: org.apache.ibatis.exceptions.PersistenceException: 
### Error building SqlSession.
### The error may exist in com.mapper.StuMapper.xml
### Cause: org.apache.ibatis.builder.BuilderException: Error parsing SQL Mapper Configuration. Cause: java.io.IOException: Could not find resource com.mapper.StuMapper.xml
······
Caused by: org.apache.ibatis.builder.BuilderException: Error parsing SQL Mapper Configuration. Cause: java.io.IOException: Could not find resource com.mapper.StuMapper.xml
······
Caused by: java.io.IOException: Could not find resource com.mapper.StuMapper.xml
······

出现这个问题说明mapper.xml没有找到

有两种情况:

  • 一、接口与xml文件路径不同
  • 二、xml存在问题

经过分析,接口与xml路径相同,情况一排除

image-20220228230953573

此时检查mybatis-config.xml文件的mapper配置

image-20220228231113661

问题出在这里,.是在source包下的包与包的分割,此处寻找的是静态资源resource包下,应该用/分割,所以正确写法如下:

image-20220228231258732

问题解决

image-20220228231334668

0x03 Spring集成Mybaits时JUnit测试问题

使用Spring集成Mybatis之后在单元测试中出现下面问题

1
2
3
4
5
6
7
8
9
10
java.lang.ExceptionInInitializerError
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
······
Caused by: java.lang.IllegalStateException: SpringJUnit4ClassRunner requires JUnit 4.12 or higher.
at org.springframework.util.Assert.state(Assert.java:73)
at org.springframework.test.context.junit4.SpringJUnit4ClassRunner.<clinit>(SpringJUnit4ClassRunner.java:104)
... 15 more

由报错 SpringJUnit4ClassRunner requires JUnit 4.12 or higher.可知JUnit版本过低导致,但是我配置JUnit版本是符合要求的。结果依然报错。

image-20220228231628903

经过研究,发现了问题。

我在创建项目时为了方便所以使用了maven 的依赖管理,将需要的依赖都放在了父项目里面,然后子项目去继承父项目的依赖,结构如下:

image-20220228231935237

问题就出在Spring集成Mybatis这个项目中,我在创建这个子项目的时候使用了maven的脚手架webapp 所以他自带了一个JUnit依赖,从而把父项目的JUnit依赖替换掉了。

又正好子项目的依赖版本低于要使用的版本,所以出现问题。

image-20220228232113775

将该依赖注释,刷新pom.xml之后再次运行单元测试。

image-20220228232225356

查询成功,问题解决。

image-20220228232253595

总结

再次回顾基础,在不使用Springboot的情况下,一时间还有点写不出来代码,尤其是spring和Mybatis的各种配置文件以及dtd 的约束,但是也让我对翻阅官方文档更加熟练。不定时还是要回顾一下基础,要知道哪里要配些什么,也不需要死记硬背,大部分的配置都在官方文档上面写了的。

温故而知新,可以为师矣

——《论语》

  • 版权声明: 本博客所有文章除特别声明外,著作权归作者所有。转载请注明出处!

扫一扫,分享到微信

微信分享二维码
  • Copyrights © 2021-2022 John Doe
  • 访问人数: | 浏览次数:

请我喝瓶快乐水吧~